Kryptronic Software Support Forum

You are viewing this forum as a guest. Login to an existing account, or create a new account, to reply to topics and to create new topics.

#1 08-02-2005 19:31:22

wclathe
Member
Registered: 03-30-2004
Posts: 12

Cybersource And Ccp51

We've been working on this for over a month now. It's getting a bit frustrating to say the least. Cybersource tells us to find out from CCP, the CCP manuals don't help... and all the topics here on cybersource seem to have different problems or answers that don't work for us.

Here is the problem, like everyone else using BofA we migrated to Cybersource. We updated CCP, we did the migration (and in the meantime also added the 'one-click' order module).

We have several problems that seem intractable.

the CC order goes fine to cybersource and takes the order. Put the billing information in and click submit. That is when the problems begin and here they are:

1. if the CC information is accepted and correct, cybersource bills the CC and sends the info back to our site and CCP, BUT... instead of going to the acceptance page it goes to the "ste_order_faildata" page. Not good for the customer!! Temporarily we changed this to read "thank you for the order, we'll confirm soon" so as not to confuse them.. and

2. If the credit card is accepted, a confirmation email is sent from cybersource to us, but there is NO information about the order that allows us to figure out what the customer bought. Just a cybersource generated order number and price and card. Not the product, not the customer name, not the CCP order number.... AND...

3. the store does not update, no product inventory update, etc. AND if....

4. if the CC information is rejected, cybersource sends back to our site and CCP BUT it only says 'order denied' in the title of the browser and then ends up on the store home with no message.

on top of all this (and unrelated i think), we can't get it to go to our secure address. Even though both cybersource and our site is secure, the user still gets a message that they are going to an insecure site.

Offline

 

#2 08-05-2005 18:10:58

wclathe
Member
Registered: 03-30-2004
Posts: 12

Re: Cybersource And Ccp51

At this point we can't get anything working and i have no idea how.

If there is anyone that thinks they can fix it (with suitable compensation of course), please contact me. If we don't get this fixed, we are going to just have to give up on CCP (changing banks is not an option).

Warren

Offline

 

#3 08-22-2005 10:29:08

webmaster
Administrator
From: York, PA
Registered: 04-20-2001
Posts: 19807
Website

Re: Cybersource And Ccp51

It sounds to me like the Cybersource integration was done improperly, or the 1 click checkout module is screwing things up.  First, check the integration by doing the following:

(1) Make sure for the Cybersource setup, you have 'Use Secure Server' set to 'No' and you have the type set up as 'Payment Form'.

(2) Copy the 'Form Content' section from the CCP admin demo and paste into your install.  Update only your store number / account.

Test.  If this fails to make things work, contact the 1 click checkout vendor and find out why that module is incompatible with Cybersource and have them correct it.


Nick Hendler

Offline

 

Board footer