Kryptronic Software Support Forum

You are viewing this forum as a guest. Login to an existing account, or create a new account, to reply to topics and to create new topics.

#1 04-30-2024 10:25:25

JonSink
Administrator
Registered: 04-29-2024
Posts: 77

SMTP Mail Setting Issue

NOTE: This post was created on 2023-08-20 on the Kryptronic eCommerce Community facebook page, which has been replaced with this forum.  All facebook support content was migrated into this forum in April 2024.

Anthony:

SMTP setting again! I gave up on this for a while, and used php mail instead, however as I had some spare time I thought I would try and get this resolved... I have put the debugger on the Mail2.php and it came up with an error........................................

Sender address rejected: not owned by user

I am on Hostinger and they have said the following: "typically appears as an error message when an email server rejects an email message because the sender's email address is not associated with the user or domain that is trying to send the message.
In your script, there may be some discrepancies between the email addresses you have entered in the SMTP username and From email address fields" I used the installer to configure the SMTP settings, so is there an error in the script?

The full output of the debugger is:

DEBUG: Recv: 220 ESMTP smtp.hostinger.com DEBUG: Send: EHLO localhost DEBUG: Recv: 250-smtp.hostinger.com DEBUG: Recv: 250-PIPELINING DEBUG: Recv: 250-SIZE 48811212 DEBUG: Recv: 250-ETRN DEBUG: Recv: 250-AUTH PLAIN LOGIN DEBUG: Recv: 250-ENHANCEDSTATUSCODES DEBUG: Recv: 250-8BITMIME DEBUG: Recv: 250-DSN DEBUG: Recv: 250 CHUNKING DEBUG: Send: AUTH LOGIN DEBUG: Recv: 334 VXNlcm5hbWU6 DEBUG: Send: b25saW5lLW9yZGVyc0BmdW5reWJ1bmt5LmNvLnVr DEBUG: Recv: 334 UGFzc3dvcmQ6 DEBUG: Send: QnVybGV5MjM4MiEj DEBUG: Recv: 235 2.7.0 Authentication successful DEBUG: Send: MAIL FROM: DEBUG: Recv: 250 2.1.0 Ok DEBUG: Send: RCPT TO: DEBUG: Recv: 553 5.7.1 : Sender address rejected: not owned by user online-orders@funkybunky.co.ukDEBUG: Send: QUIT DEBUG: Recv: 221 2.0.0 Bye

Nick:

For your server setup it looks like you'll need for force all mails to come from your address. Perhaps you configured mail to use SMTP by logging into your account? Regardless, to handle this, access System / Component / Settings / Mail Settings and set the Override From Address setting to true/on.

Offline

 

Board footer