Kryptronic Software Support Forum

You are viewing this forum as a guest. Login to an existing account, or create a new account, to reply to topics and to create new topics.

#1 02-28-2020 09:38:58

sqm24
Member
Registered: 01-24-2018
Posts: 12

User table not updating

Some time ago we imported users into the database. All seemed to have gone well, but we have found out that we are having problems with trying to update a users record from the Kryptronic admin interface.

We tried to change a field and it failed to update informing us that there were fields left blank. It highlighted the fields and I filled them in. However, on resubmitting the form it reported the same error, but this time there was no highlighting of any empty fields. So I am at a loss as to what is wrong.

I am assuming that when we imported the data we missed something, perhaps a field that is not shown on the form but is there for some behind the scenes purpose. Is there a list somewhere of the database fields that must be filled in on the user table?

Simon

Offline

 

#2 03-02-2020 08:58:54

webmaster
Administrator
From: York, PA
Registered: 04-20-2001
Posts: 19482
Website

Re: User table not updating

It may be a hidden field that's required.  You can check under System / Database / Raw DB Admin, choose to Maintain the core_users table and you'll see all the field definitions - and which ones are required (NOT NULL).


Nick Hendler

Offline

 

#3 03-05-2020 04:42:44

sqm24
Member
Registered: 01-24-2018
Posts: 12

Re: User table not updating

Thanks for pointing me in the right direction.

Found I needed to put something in the two passchange fields; empty string was not enough.

Offline

 

Board footer