Kryptronic Software Support Forum

You are viewing this forum as a guest. Login to an existing account, or create a new account, to reply to topics and to create new topics.

#1 10-03-2019 08:27:24

zanart
Member
From: bedford
Registered: 04-02-2008
Posts: 1642
Website

PHP version.

Hi Nick,

Just a quick question,

I changed the PHP version to 7.3 and got this error when checking out using a credit/debit card payment method:

The mcrypt PHP extension is not loaded. This processing module requires the mcrypt PHP extension to be loaded in order to function. This script attempted to change this value at runtime, however the current server configuration did not permit the script to make this runtime change. Contact your server administrator and request that the mcrypt PHP extension be loaded at run time.

Everything seems OK with php 7.1.

Is that error to be expected with the latest software version????


- Euorpacart 8

Offline

 

#2 10-05-2019 04:42:02

sdn
Member
From: UK
Registered: 05-29-2007
Posts: 828

Re: PHP version.

We had the same problem with PHP7.2. See posts at https://forum.kryptronic.com/viewtopic.php?id=33844 where Nick said, "The solution there would be to install mcrypt with PHP 7.2 when you install that PHP verison."

https://secure.php.net/manual/en/migrat … ecated.php states "The mcrypt extension has been abandonware for nearly a decade now, and was also fairly complex to use. It has therefore been deprecated in favour of OpenSSL, where it will be removed from the core and into PECL in PHP 7.2."

After reading the info at https://lukasmestan.com/install-mcrypt- … in-php7-2/ I decided to stick with 7.1 as it was looking too complicated and potentially flaky a workaround.

Could K9 be changed to use OpenSSL instead? Article at https://paragonie.com/blog/2015/05/if-y … g-it-wrong

Update: I just found a better guide to installing it at https://www.codelibrary.me/2018/07/29/i … nel-server

Last edited by sdn (02-19-2020 09:48:40)


Simon

Offline

 

#3 10-07-2019 09:47:16

webmaster
Administrator
From: York, PA
Registered: 04-20-2001
Posts: 19509
Website

Re: PHP version.

The mcrypt library is used only by two gateway integrations in K9 and not part of the base package.  Those gateway integrations are ProTX (form) and HSBC (form).  I've looked at moving from mcrypt to openssl for those two gateways and it's doable and been put on the list for the next update.  In the interim, it is possible to install mycrypt with PHP7.2, as you found, and if you need to, that can be done.  However, sticking with PHP7.1 until the software is updated to use openssl is just fine.


Nick Hendler

Offline

 

#4 10-07-2019 09:53:10

zanart
Member
From: bedford
Registered: 04-02-2008
Posts: 1642
Website

Re: PHP version.

Thanks guys.

No issues with sticking to 7.1 so won't waste any brain cells working out how to install mycrypt.


- Euorpacart 8

Offline

 

#5 02-19-2020 06:34:27

sdn
Member
From: UK
Registered: 05-29-2007
Posts: 828

Re: PHP version.

Server has just updated to v86.04 and is warning that:

PHP 7.1 reached EOL
We strongly recommend that you use a version that is still supported upstream.
If you do continue to use it you are susceptible to bugs and security issues that remain.
Go to MultiPHP Manager page and update to a supported version.

Versions 7.2 and 7.3 are available. Is one going to be preferable to the other?


Simon

Offline

 

#6 02-19-2020 09:06:41

webmaster
Administrator
From: York, PA
Registered: 04-20-2001
Posts: 19509
Website

Re: PHP version.

Use 7.2 for now.  I believe we're OK on 7.3, but I need to verify whether any of the bundled PEAR modules require updates.


Nick Hendler

Offline

 

#7 02-19-2020 09:47:09

sdn
Member
From: UK
Registered: 05-29-2007
Posts: 828

Re: PHP version.

OK thanks.

We have updated to 7.02 and installed mcrypt as instructions at

https://www.codelibrary.me/2018/07/29/i … nel-server

Seems to be working OK.

Last edited by sdn (02-19-2020 09:49:05)


Simon

Offline

 

Board footer