Kryptronic Software Support Forum

You are viewing this forum as a guest. Login to an existing account, or create a new account, to reply to topics and to create new topics.

#1 09-12-2015 13:44:41

ThomasGiannou
Member
Registered: 02-10-2007
Posts: 184

Security Update problem

When I ran step 12, the following message displayed:

An error was encountered while installing the Store Component Online Processing module. Error Information: The installer was unable to create the file /apps/ecom/ECOM_OLP/install/data_core_modules_2.xml while attempting to install the ECOM_OLP version 8.0.8 module. Error Information: The file_read() function was unable to locate the file requested. File: /temp/5628251e7ae5/ECOM_OLP-8.0.8/PRIVATE/apps/ecom/ECOM_OLP/install/data_core_modules_2.xml

I reran step 12 again, making sure I selected "YES" on "Yes, reinstall/update components and modules".   I had that "yes" set on the first attempt to run step 12.   The second time, everything seemed to work fine and no error messages were displayed.

After finishing the whole process, I saw the online processing module was at 8.0.8.   

The question I have:   Is everything installed properly.  I don't know what else I could have done to resolve the above error message.  Should I be concerned?

Offline

 

#2 09-13-2015 09:28:01

webmaster
Administrator
From: York, PA
Registered: 04-20-2001
Posts: 19557
Website

Re: Security Update problem

Please accept my apologies on this.  The package file in the ECOM_OLP module was referencing incorrect XML filenames in the package.  I've corrected the package file.  You can re-run your installer and it will run just fine, but you don't need to.  The error was in updating definitions for database entries you already have have set, that would not have updated when running the installer. Basically you're good to go.


Nick Hendler

Offline

 

#3 09-14-2015 09:27:32

121NetDesign
Member
From: Surrey, UK
Registered: 05-10-2007
Posts: 427

Re: Security Update problem

Is it possible just to replace the current ECOM_OLP file with ECOM_OLP 8.0.8 and make the database changes?

We have a very modified version of Europcart and dont want to risk running the update.

If so, how do I get a copy of the ECOM_OLP.php file?

Ours is currently var $version = '8.0.6';

Thanks in Advance.

Tommy


Tommy Lee

Offline

 

#4 09-15-2015 14:01:17

webmaster
Administrator
From: York, PA
Registered: 04-20-2001
Posts: 19557
Website

Re: Security Update problem

It's actually the files in the {private}/apps/ecom/ECOM_OLP/ext directory which were updated.  Contact support and we can get you a copy of what you need.


Nick Hendler

Offline

 

Board footer