Kryptronic Software Support Forum

You are viewing this forum as a guest. Login to an existing account, or create a new account, to reply to topics and to create new topics.

#1 08-25-2015 12:32:18

Blitzen
Member
From: USA
Registered: 01-01-2005
Posts: 936

Authorize.Net Technical Updates

My client just received a notice about Authorize.Net Technical Updates.
Are you going to update the software for this? If so, when can we expect it?

Thanks! Here is their notice.

Over the next few months, there are several updates and enhancements we are making to our systems that you need to be aware of. They are all technical in nature and may require the assistance of your web developer or shopping cart/payment solution provider.
Please read this notice carefully, and if you need to find a developer to help you, please check out our Certified Developer Directory at wwwauthorize.net/cdd.


Security Certificate Upgrades to api.authorize.net
As part of our continuous upgrades to enhance system performance and security, on September 21, 2015, we are upgrading api.authorize.net to new security certificates, which are signed using Security Hash Algorithm 2 (SHA-2) and 2048-bit signatures.
These upgrades were already completed on secure.authorize.net in May. If your website or payment solution connects to api.authorize.net and any updates are necessary to use the new certificates, please refer to this blog post in our Developer Community, which has all of the certificate information you and your developer will need for this update. Our sandbox environment has already been updated so that you can validate that your solution will continue to work using SHA-2 signed certificates, prior to September 21st.
After the update is complete on September 21st, any website or payment solution that connects via api.authorize.net that cannot validate SHA-2 signed certificates will fail to connect to Authorize.Net's servers.

Transaction ID Changes
In October of this year, due to system updates, it will be possible to receive Authorize.Net IDs (Transaction ID, Batch ID, etc.) that are not in sequential order.
Currently, if you receive a Transaction ID of "1000," you could expect that the next Transaction ID would not be less than 1000. However, after the updates, it will be possible to receive a Transaction ID less than the one you previously received.
If your system has any functionality that expects Authorize.Net-generated IDs to be sequential, please update it immediately so that you will not see any disruptions to your solution.
Additionally, please make sure that your solution does not restrict any Authorize.Net ID field to 10 characters. If you are required to define a character limit when storing any of our IDs, the limit should be no less than 20 characters.

TLS Remediation for PCI DSS Compliance
As you may already be aware, new PCI DSS requirements state that all payment systems must disable TLS 1.0 by June 30, 2016. To ensure that we are compliant ahead of that date, we will be disabling TLS 1.0 first in the sandbox environment and then in our production environments. Both dates are still to be determined, but please make sure your solutions are prepared for this change as soon as possible.
For more information, including updates to the dates we anticipate disabling TLS in each environment, please refer to our previous blog post. We will also send another email about TLS once we have a final date in place.

Akamai Reminder
Last, but not least, we previously announced our Akamai implementation plan and timelines. Using Akamai's technology will provide Authorize.Net a superior level of reliability, as it helps safeguard against interruptions caused by issues beyond our direct control, such as Internet congestion, fiber cable cuts and other similar issues.
If you have not already, please review the announcement and the Akamai FAQs to determine what action you should take for your particular solution.

Offline

 

#2 08-26-2015 07:12:21

webmaster
Administrator
From: York, PA
Registered: 04-20-2001
Posts: 19818
Website

Re: Authorize.Net Technical Updates

Thank you.  We've been getting this notice sent to us from all Authorize.net clients.  No changes are required on your end, unless you're self-hosted and your server cannot communicate via TLS1.1 or better.  No software changes required.  No changes for Kryptronic Managed Hosting clients.


Nick Hendler

Offline

 

Board footer