Kryptronic Software Support Forum

You are viewing this forum as a guest. Login to an existing account, or create a new account, to reply to topics and to create new topics.

#1 06-27-2012 22:38:39

jonaha
Member
Registered: 11-01-2006
Posts: 190

Script Error

I recently updated my server and my v7 cart stopped working. I get the following error message:


Script Execution Error
Function split() is deprecated

File: /home/guestbe/public_html/khxc-private/core/KHXC/KHXC.php Line: 1902 Error Number: 8192
1999-2012 Kryptronic, Inc. All rights reserved worldwide. Kryptronic, the Kryptronic logo and all Kryptronic software names and logos are trademarks of Kryptronic, Inc. All Kryptronic software is copyrighted and the intellectual property of Kryptronic, Inc. All Kryptronic software is developed and distributed under license by Kryptronic, Inc. Application Information: https://kryptronic.com/


I tried running the installer and get the following error:


Script Execution Error
Function split() is deprecated

File: /installer.php Line: 7991 Error Number: 8192
1999-2012 Kryptronic, Inc. All rights reserved worldwide. Kryptronic, the Kryptronic logo and all Kryptronic software names and logos are trademarks of Kryptronic, Inc. All Kryptronic software is copyrighted and the intellectual property of Kryptronic, Inc. All Kryptronic software is developed and distributed under license by Kryptronic, Inc. Application Information: https://kryptronic.com/


The site is http://guest-bed.com. What can I do to fix the problem?

Offline

 

#2 06-27-2012 23:06:20

dh783
Moderator
From: Avondale, Arizona
Registered: 04-06-2005
Posts: 6233
Website

Re: Script Error

What version are you running? Your PHP has been up graded to 5.3.x you will  need to correct ccps code to get it to operate  correctly, if your running ccp6 I have a file that details all the changes needed to make it work again.

Offline

 

#3 06-28-2012 03:26:11

jonaha
Member
Registered: 11-01-2006
Posts: 190

Re: Script Error

I am running version 7.

Offline

 

#4 06-28-2012 03:31:29

jonaha
Member
Registered: 11-01-2006
Posts: 190

Re: Script Error

Sorry, I am running Software Version:  6.6.5. but there is also a version 7 site that is not working properly on this server.

Offline

 

#5 06-28-2012 07:01:17

jj1987
Moderator
From: Orlando, FL
Registered: 07-14-2008
Posts: 502
Website

Re: Script Error

jonaha wrote:

Sorry, I am running Software Version:  6.6.5. but there is also a version 7 site that is not working properly on this server.

This is a result of upgrading to a version of PHP which is incompatible.  For v7, I would update to the latest version (free), and for the v6 I would consider the upgrade or use the file John has offered to you.



-James Garrett

Offline

 

#6 06-28-2012 07:08:04

jonaha
Member
Registered: 11-01-2006
Posts: 190

Re: Script Error

How can I upgrade, both versions, if the installers are not working?

Offline

 

#7 07-12-2012 03:17:37

Panmanjon
Member
From: Manchester UK
Registered: 08-18-2004
Posts: 336
Website

Re: Script Error

Geetings - I have run into the same problem - I have 3 uropacart ver 7 and 6 version 6 sites to move onto a new server - I have onlt attempted to move 1 version 6 over and am getting the error as I am running version 3 PHP

I would very much appreciate the fixes for this please

Thanks

Paul

Offline

 

#8 07-12-2012 10:36:36

dh783
Moderator
From: Avondale, Arizona
Registered: 04-06-2005
Posts: 6233
Website

Re: Script Error

Are you sure about the PHP version being 3?

John

Offline

 

#9 07-12-2012 18:52:48

Panmanjon
Member
From: Manchester UK
Registered: 08-18-2004
Posts: 336
Website

Re: Script Error

oops - its running  PHP Version 5.3.13 and not 3 - any ccp ver 7 site with 7.1.3 or above is ok for PHP 5.3 - I have 2 sites at europacart version 7.1.2 and am a bit worried about upgrading because Nick did some big mods on one of them for me. But I will bite the bullet and do the upgrade - its the ccp version 6 sites I need the fix for please

Re version europacart 7 builds - when I look at system I can see a whole list of versions against different titles for example installer says 7.0.0 and others say 7.1.2 etc - which one do the updates actually refer to when statementing 7.1.2 to 7.1.3 please?

Thanks

Offline

 

#10 07-02-2013 12:45:06

smudge
Member
Registered: 01-11-2011
Posts: 3

Re: Script Error

I am having the same problem how can i fix it? the version is 6.6.8

Offline

 

#11 07-03-2013 14:38:14

webmaster
Administrator
From: York, PA
Registered: 04-20-2001
Posts: 19513
Website

Re: Script Error

If you have ClickCartPro v6 and run into an error with PHP 5.3 or greater being installed on your server, upgrade to ClickCartPro v8, or ask your host to reduce your PHP version to 5.2.

If you have ClickCartPro v7 (7.1.1 and lower) and run into an error with PHP 5.3 or greater being installed on your server, update (for free) to the latest version 7 using these instructions:

https://kryptronic.com/cms-xmodnewsrss_ … 2012A.html


Nick Hendler

Online

 

#12 07-04-2013 13:50:01

dh783
Moderator
From: Avondale, Arizona
Registered: 04-06-2005
Posts: 6233
Website

Re: Script Error

If you want to keep your ccp6 running I have a listing of changes to make ccp6 php5.3.x compatible.

John

Offline

 

Board footer