Kryptronic Software Support Forum

You are viewing this forum as a guest. Login to an existing account, or create a new account, to reply to topics and to create new topics.

#26 05-18-2004 16:43:02

scoutch
Banned
Registered: 07-03-2003
Posts: 3167

Re: At The End Of My Rope . . .

In this case, the answer is : Yes. smile


______________________________________________

THIS USER HAS BEEN BANNED FROM THIS FORUM.

If this post contains any language related to
code samples, advice, etc., please read this
entire thread before making a decision to use
this post as a basis for any change to your
software installation.
______________________________________________

Offline

 

#27 05-19-2004 22:23:11

0_limit
Member
Registered: 05-19-2004
Posts: 12
Website

Re: At The End Of My Rope . . .

I am experiencing the same problem.  I had the Linkpoint API working with ClickCartPro about a month ago but when I tested it out today it returned a Declined status. 

I tested the connection using one of Linkpoints test scripts and it worked fine.  The script I used was lptest_minimum.pl which comes with the perl version of Linkpoint API downloaded from linkpoint.com at the following URL:



I added the code to ste_olp.pl to return the error results and I got a statusMessage=cURL connection error.  I have yet to get a new key but if that worked can you please post?

What doesn't make sense to me is that it was working last month and I haven't changed anything that has to do with the processing functions. 

Offline

 

#28 05-19-2004 22:27:54

scoutch
Banned
Registered: 07-03-2003
Posts: 3167

Re: At The End Of My Rope . . .

I'd send this documentation to Nick at : support@kryptronic.com . If Linkpoint did made new modifications, I'm sure he could modify ste_opl.pl file.


______________________________________________

THIS USER HAS BEEN BANNED FROM THIS FORUM.

If this post contains any language related to
code samples, advice, etc., please read this
entire thread before making a decision to use
this post as a basis for any change to your
software installation.
______________________________________________

Offline

 

#29 05-19-2004 23:23:14

0_limit
Member
Registered: 05-19-2004
Posts: 12
Website

Re: At The End Of My Rope . . .

I'm going to have Linkpoint issue me a new key.  It seems that LPERL.pm is working fine and I can't find anything wrong with the ste_olp_linkpointapi_proc function in ste_olp.pl. 

If the new key works I'll post...and if not LPERL.pm has a debugging function which may help.  I'm hoping the key will work though cause its a lot easier  :-)

Thanks

Offline

 

#30 05-19-2004 23:38:38

pmitchell
Member
Registered: 05-18-2004
Posts: 10

Re: At The End Of My Rope . . .

I had linkpoint give me a new key and that didn't help any.  According to linkpoint api customer service, it looks like a port 1129 problem.  I've been dealing with ipowerweb customer service and after going through a few layers of idiots I've received an email staiting that they keep port 1129 closed due to security reasons.  I've now asked them to forward my situation to someone who make more than $5 a hour in a dire hope that I can get someone who knows what I'm talking about to fix port 1129 for me.

I'm lost...

Offline

 

#31 05-19-2004 23:42:41

0_limit
Member
Registered: 05-19-2004
Posts: 12
Website

Re: At The End Of My Rope . . .

I just got off the phone with Card Services International and they said that all they would be doing for my key is re-sending me my current key

If anybody resolves the problem with Linkpoint API not processing please post or send me an e-mail.

Thanks

Offline

 

#32 05-20-2004 14:17:18

pmitchell
Member
Registered: 05-18-2004
Posts: 10

Re: At The End Of My Rope . . .

Does anybody have any experience with ipowerweb and port 1129? 

Do they keep it closed most of the time?

Is there anyway to get around the need for port 1129 with linkpoint API?

Offline

 

#33 05-20-2004 14:29:43

EagleWolf
Member
From: Daytona Beach, FL
Registered: 07-27-2003
Posts: 979

Re: At The End Of My Rope . . .

pmitchell - no offense and no I am not trying to sell my services, but why not find a host that you can work with that does not have this problems? That sounds like it might be easier.


Chris
<a href='mailto:webmaster@equivity.com'>webmaster@equivity.com</a>
-

Offline

 

#34 05-20-2004 15:09:11

pmitchell
Member
Registered: 05-18-2004
Posts: 10

Re: At The End Of My Rope . . .

No offense taken. 

I've had at least 20 websites over the past 6 years, but this is the first time I've had to have a merchant account. 

It has been my experience that you will always have some problem with the hosting company, so I look for a company that has the easiest system to use.  With the exception of this port 1129 deal, I haven't had any problems with ipowerweb. 

I've liked their systems, decent bandwith, way more storage that I've ever needed, and a good price.

I think our next move will probably be to a dedicated server for our expected needs. 

Offline

 

#35 05-20-2004 15:23:26

simcoweb
Banned
Registered: 08-14-2003
Posts: 128

Re: At The End Of My Rope . . .

when we were having this same problem we contacted iPowerweb about the port 1129. They informed us they are not blocked nor were they ever blocked. all we did was get the correct path to curl and make sure the settings in Linkpoint were correct.


Web Design - Ecommerce Specialists - CCP Mods

Flash Templates - Swish Templates - Web Templates

Offline

 

#36 05-20-2004 15:34:48

pmitchell
Member
Registered: 05-18-2004
Posts: 10

Re: At The End Of My Rope . . .

Which settings in linkpoint are you referring to?

Offline

 

#37 05-26-2004 10:45:58

webmaster
Administrator
From: York, PA
Registered: 04-20-2001
Posts: 19514
Website

Re: At The End Of My Rope . . .

A cURL connection error means an incorrect cURL path is entered in Global Settings | Manage Program Settings.  I think that host uses '/usr/local/bin/curl' but all their techs say it's at '/usr/bin/curl'.  Not sure, but it's worth a try.


Nick Hendler

Offline

 

#38 12-22-2004 11:44:09

jclanin
Member
From: Atlanta, GA
Registered: 05-05-2004
Posts: 164
Website

Re: At The End Of My Rope . . .

I've tried everyting I can think of but still can't get LinkPoint API to work.  CCP never makes the connection...

I've  got the correct Certificate/Key installed in the LinkPoint.txt file.  The Store # and User ID are in the form in CCP51.  I've added the password to the Transaction key/password field.  I've made absolutely sure that the path to cURL is correct.  I've made sure that port # 1129 is open.

I've tried to debug the ste_olp.pl file with the following code:

print "Content-type: text/html\n\n";
foreach $key(keys %ret) {print "$key = $ret{$key}<BR>\n";}

I don't see anything accept "Declined" when I try to place an order.  Even the "debug" is not working for me...  --I've tried several different cards also.

Please help - this is extremely frustrating. LinkPoint says everything is fine on their end...

thanks,

JC


Jim Clanin

Offline

 

#39 01-14-2005 15:16:25

webmaster
Administrator
From: York, PA
Registered: 04-20-2001
Posts: 19514
Website

Re: At The End Of My Rope . . .

This was handled via a support ticket.  First it was a cert problem, then an issue with cURL.


Nick Hendler

Offline

 

#40 01-14-2005 15:18:55

jclanin
Member
From: Atlanta, GA
Registered: 05-05-2004
Posts: 164
Website

Re: At The End Of My Rope . . .

It's still not fixed Nick - unless you did something today.

-JC


Jim Clanin

Offline

 

#41 01-18-2005 23:48:41

pmitchell
Member
Registered: 05-18-2004
Posts: 10

Re: At The End Of My Rope . . .

Does anyone know if ipower has changed their cURL settings?  I've now got two click cart pro websites and for some reason they both stopped processing CC orders recently. 

Nothing is showing up in the yourpay log at all (either denials or acceptance).  This makes me think that either something with ipower has changed or something with CCP51 is no longer set right. 

I would gladly do a support ticket if you guys think you can get it going again.

Please help.

Offline

 

#42 02-08-2005 09:00:21

webmaster
Administrator
From: York, PA
Registered: 04-20-2001
Posts: 19514
Website

Re: At The End Of My Rope . . .

Add the debug code above and see what's being returned by lperl.  If that doesn't shed light on the issue, post back the debug info here.


Nick Hendler

Offline

 

#43 02-10-2005 14:55:16

pmitchell
Member
Registered: 05-18-2004
Posts: 10

Re: At The End Of My Rope . . .

I put in a support ticket with you guys and I was told that the problem was with the cURL at ipower.  Ipower is saying that everything is running right on their end with the cURL.

If I change cc processors to one that doesn't use cURL will I still run into the same problem?

Any favorites on the cc processors?

Offline

 

#44 02-10-2005 15:13:56

EagleWolf
Member
From: Daytona Beach, FL
Registered: 07-27-2003
Posts: 979

Re: At The End Of My Rope . . .

I use Authorize.Net and have never had a problem with them


Chris
<a href='mailto:webmaster@equivity.com'>webmaster@equivity.com</a>
-

Offline

 

#45 02-12-2005 13:50:11

dmannin7
Member
Registered: 02-01-2005
Posts: 10

Re: At The End Of My Rope . . .

I am having the same issue. My cart won't connect with Linkpoint API. I've verified cURL path, port 1129, the key is in the right place, and my username is in the right place. I've debugged it and here's what comes back:

statsapproval=
statusMessage=
Content-type: text/html

Offline

 

#46 02-12-2005 14:01:35

TerryA
Member
From: Sanford, Fl
Registered: 07-14-2003
Posts: 1322
Website

Re: At The End Of My Rope . . .

I had one the other day that was having a problem getting connected.  I looked at the key file and it was double spaced on every line.  This file needs to have no line spaces between the lines.  Make sure it looks like this: (Note that I have removed several lines of the code to shorten the post)

-----BEGIN RSA PRIVATE KEY-----
MIICXQIBAAKBgQDDZVyEWca2qkpXjr82CGtqYYNso5/hus63vQnhZlwmNzl1Wkqi
vKnZlDtlITWMoBOGVkwkHBgu7vc5QEudyQRE08NFmC3G3cuC2qU+l6S4xJCGxXxb
JZagd9QloaQivqHkdZ3mXaIXcpa8CgpOYf8zr4GST/MBjRjShyuvy2+aiwIDAQAB
AhvcTK/t8wOC32OEcaMECQQCUf77r3Kp8cez3enBQYCI0/yQnq2c0YKtdgCUQuJeJ
GbI7ukms0np9WXfQrham8OEOUCIIY6VGqRD2t3l02qih
-----END RSA PRIVATE KEY-----
-----BEGIN CERTIFICATE-----
MIICbDCCAdWgAwIBAgIBADANBgkqhkiG9w0BAQQFADB8MQswCQYDVQQGEwJVUzEL
MAkGA1UECBMCVFgxEDAOBgNVBAcTB0hPVVNUT04xFDASBgNVBAoTC0hFWSBTVFVE
SU9TMRAwDgYDVQQDEwdNQU5BR0VSMSYwJAYJKoZIhvcNAQkBFhdoZXktc3R1ZGlv
RRbWRdyBMeUpNl5shjJnE5RuyYYYpK9uGmNy2vjgchJFsmR2+sbd9Co+CGBIsaNC
puMjKMZk2iKzjBs7WhSsc2hcZbCoGEUDauxXtHjV48ibmmTPBhoHUK/DqrntwEmQ
-----END CERTIFICATE-----

Make sure there are no spaces or line ending before the begin line and none after the end line.

Offline

 

#47 02-12-2005 22:00:31

dmannin7
Member
Registered: 02-01-2005
Posts: 10

Re: At The End Of My Rope . . .

I double checked, there were absolutely no spaces whatsoever. I wish that was it. Any other ideas?

Offline

 

#48 02-12-2005 22:17:20

TerryA
Member
From: Sanford, Fl
Registered: 07-14-2003
Posts: 1322
Website

Re: At The End Of My Rope . . .

If it isn't the jey file, and you have the correct info in the payment method, then it has got to be a problem with cURL.  Either the location path or cURL is not installed correctly.

Offline

 

#49 02-13-2005 12:32:50

dmannin7
Member
Registered: 02-01-2005
Posts: 10

Re: At The End Of My Rope . . .

Just got off the phone with the hosting company yet again. Just to verify, I do need port 1129 open through the hosting company, right? Well now they are saying that I shouldn't need it open on their end, just with Linkpoint API. According to the guy I talked to at the hosting company, easy cgi, he says that port is closed on their end and I shouldn't need to have it open.

He also gave me yet another path to cURL, which doesn't sound at all right to me, but it's c:/curl/curl.exe.  I've tried some variations to this and none work.

I'm so confused, is this a cURL problem or a port problem? I've gotten 2 different answers from 2 people at easy cgi, I don't know which is right.

Do I need port 1129 open on the hosting company's end or just on Linkpoint's end?

Thanks for all your help!

Offline

 

#50 03-09-2005 09:15:09

webmaster
Administrator
From: York, PA
Registered: 04-20-2001
Posts: 19514
Website

Re: At The End Of My Rope . . .

You don't need port 1129 opened on your end.  Linkpoint needs it open - which they have open already for everyone.  Did you implement the debug code above to see if the module is actually interfacing with cURL?  Is some other error message being presented?


Nick Hendler

Offline

 

Board footer