Kryptronic Software Support Forum

You are viewing this forum as a guest. Login to an existing account, or create a new account, to reply to topics and to create new topics.

#1 12-22-2019 00:20:23

polarize
Member
Registered: 11-15-2004
Posts: 276

Google Missing value for shipping rate [shipping weight]

Hello,

I am getting an error on all of our items from one website from Google Shopping Ads as "Missing value for shipping rate [shipping weight]".  I double checked the items and they all contain weights so I'm not sure if there is another way we can confirm the feed is working and gaining access to the shipping weight information.  Is there anything we should check to get this working properly?

Thanks


Using Kryptronic K9! smile
Previous Versions:
ClickCartPro 8
ClickCartPro 7
ClickCartPro 6
ClickCartPro 5.1

Offline

 

#2 12-23-2019 09:28:14

webmaster
Administrator
From: York, PA
Registered: 04-20-2001
Posts: 19525
Website

Re: Google Missing value for shipping rate [shipping weight]

Check the feed file - https://yourdomain.com/utilities/googebase.xml.  Are the weights in there?


Nick Hendler

Offline

 

#3 12-23-2019 10:46:36

polarize
Member
Registered: 11-15-2004
Posts: 276

Re: Google Missing value for shipping rate [shipping weight]

Hello Nick,

Our feed for this is coming up as https://domain.com/utilities/googlebase-DOMAIN.xml

Of course domain is our website domain and after googlebase- is a partial domain name as formatted above.

The shipping weights are all in there.

Thanks


Using Kryptronic K9! smile
Previous Versions:
ClickCartPro 8
ClickCartPro 7
ClickCartPro 6
ClickCartPro 5.1

Offline

 

#4 12-23-2019 12:14:39

polarize
Member
Registered: 11-15-2004
Posts: 276

Re: Google Missing value for shipping rate [shipping weight]

Hello Nick,

I think we may have figured it out.  We had to delete the feed and add it back in to fetch. Now we are getting some corrections showing up.  Weird but it seems to be working now. Thanks Again smile


Using Kryptronic K9! smile
Previous Versions:
ClickCartPro 8
ClickCartPro 7
ClickCartPro 6
ClickCartPro 5.1

Offline

 

#5 12-23-2019 16:58:04

polarize
Member
Registered: 11-15-2004
Posts: 276

Re: Google Missing value for shipping rate [shipping weight]

We have two multisites. Are both sites being submitted on the same googlebase feed?  I'm not seeing any products that are posted on the other website.


Using Kryptronic K9! smile
Previous Versions:
ClickCartPro 8
ClickCartPro 7
ClickCartPro 6
ClickCartPro 5.1

Offline

 

#6 12-24-2019 08:08:56

webmaster
Administrator
From: York, PA
Registered: 04-20-2001
Posts: 19525
Website

Re: Google Missing value for shipping rate [shipping weight]


Nick Hendler

Offline

 

#7 12-24-2019 09:29:30

polarize
Member
Registered: 11-15-2004
Posts: 276

Re: Google Missing value for shipping rate [shipping weight]

The file is showing up for the multisite ID but a feed is not generating for the default site....

https://domain.com/utilities/googlebase.xml

I checked through ftp as well and the googlebase.xml file for the default site doesn't exist within the utilities folder.

Thanks


Using Kryptronic K9! smile
Previous Versions:
ClickCartPro 8
ClickCartPro 7
ClickCartPro 6
ClickCartPro 5.1

Offline

 

#8 12-24-2019 10:07:18

spidevc
Member
Registered: 07-21-2016
Posts: 1

Re: Google Missing value for shipping rate [shipping weight]

How often does the
https://domain.com/utilities/googlebase-MULTISITEID.xml update ???
I have changed and fixed many issues in our inventory records and product offers... Yet the xml is not reflecting that and therefore our Merchant center is not updating our fixed issues for the items we have fixed.
i went directly to the link for our xml and verified that it's not updating .. changed many things to fix issues yesterday and xml today still doesn't show these changes

How do we update our xml file from the backend our our website to be able to fetch our feed from the xml on Merchant center to update the issues we fixed?

Thanks.

Offline

 

#9 12-26-2019 11:15:42

webmaster
Administrator
From: York, PA
Registered: 04-20-2001
Posts: 19525
Website

Re: Google Missing value for shipping rate [shipping weight]

spidevc wrote:

How often does the
https://domain.com/utilities/googlebase-MULTISITEID.xml update ???
I have changed and fixed many issues in our inventory records and product offers... Yet the xml is not reflecting that and therefore our Merchant center is not updating our fixed issues for the items we have fixed.
i went directly to the link for our xml and verified that it's not updating .. changed many things to fix issues yesterday and xml today still doesn't show these changes

How do we update our xml file from the backend our our website to be able to fetch our feed from the xml on Merchant center to update the issues we fixed?

Thanks.

Once every 24 hours.


Nick Hendler

Offline

 

#10 12-26-2019 11:16:22

webmaster
Administrator
From: York, PA
Registered: 04-20-2001
Posts: 19525
Website

Re: Google Missing value for shipping rate [shipping weight]

polarize wrote:

The file is showing up for the multisite ID but a feed is not generating for the default site....

https://domain.com/utilities/googlebase.xml

I checked through ftp as well and the googlebase.xml file for the default site doesn't exist within the utilities folder.

Thanks

Does the main site have the Google Shopping Feed module activated under Store / Component / Settings?


Nick Hendler

Offline

 

#11 12-26-2019 11:35:15

polarize
Member
Registered: 11-15-2004
Posts: 276

Re: Google Missing value for shipping rate [shipping weight]

webmaster wrote:

Does the main site have the Google Shopping Feed module activated under Store / Component / Settings?

Yes sir,  The setting is on.  I thought this was a global setting since it didn't say whether the Google Shopping Feed in settings is for default or any multisites.

I'm not sure if this could have had an effect but in Multisites overide I added in our separate Analytics ID: that applies to the multisite under core.seo_googleacct but didn't think that should be an issue but rather a separation of accounts for google analytics because each site has its own analytics account id.  Could I be missing something here?


Using Kryptronic K9! smile
Previous Versions:
ClickCartPro 8
ClickCartPro 7
ClickCartPro 6
ClickCartPro 5.1

Offline

 

#12 12-27-2019 08:46:58

webmaster
Administrator
From: York, PA
Registered: 04-20-2001
Posts: 19525
Website

Re: Google Missing value for shipping rate [shipping weight]

The Google Analytics id for the default site should be entered under settings (System / Component / Settings / Search Engine Optimization) and can be overridden for the multisite using multisite settings overrides (System / MultiSite / MultiSite Sites) using setting id 'core.seo_googleacct'.

Isn't your main site (DEFAULT) wholesale only?  If no retail pricing is available for items a feed won't be generated.


Nick Hendler

Offline

 

#13 12-27-2019 10:17:23

polarize
Member
Registered: 11-15-2004
Posts: 276

Re: Google Missing value for shipping rate [shipping weight]

We do have some items showing up on the retail side of the default site and plan to have more publicly available products as time goes on.  If any items are available retail it should generate a file correct??  I'm going to review some of the products to ensure no restriction on the frontend to see if that makes a difference.

Sitemap files are being generated for both sites however but only one googlebase file for the multisite.

Last edited by polarize (12-27-2019 10:21:37)


Using Kryptronic K9! smile
Previous Versions:
ClickCartPro 8
ClickCartPro 7
ClickCartPro 6
ClickCartPro 5.1

Offline

 

#14 12-30-2019 09:31:20

webmaster
Administrator
From: York, PA
Registered: 04-20-2001
Posts: 19525
Website

Re: Google Missing value for shipping rate [shipping weight]

Do the sitemaps have any /Item/ URLs in them?  Do you show pricing on the default site for any items for guests?


Nick Hendler

Offline

 

#15 12-30-2019 22:21:14

polarize
Member
Registered: 11-15-2004
Posts: 276

Re: Google Missing value for shipping rate [shipping weight]

We apparently still have it locked down.  Thanks Nick smile


Using Kryptronic K9! smile
Previous Versions:
ClickCartPro 8
ClickCartPro 7
ClickCartPro 6
ClickCartPro 5.1

Offline

 

Board footer