Kryptronic Software Support Forum

You are viewing this forum as a guest. Login to an existing account, or create a new account, to reply to topics and to create new topics.

#1 08-22-2012 13:52:32

ThomasGiannou
Member
Registered: 02-10-2007
Posts: 184

Several things are not working in V8 after the install.

When I try to checkout of the cart the following url is produced:
https://www.tandjenterprises.com/CCPRO/CheckoutIntro

Then I get a 404 error.   

How can I correct this problem?   

Where is "Checkoutintro" defined? 

When I link over to a product in the cart, the product displays okay, but at the top of the creen a menu is displayed.....
Home  Shopping Cart  Checkout  Your Account  Contact

None of the links seem to work on that menu.   
When I click on "Home", a url is formed:  http://www.tandjenterprises.com/CCPRO/splash  and a 404 error comes up with page not found.

When I click on "Shopping Cart", a url is formed:  http://www.tandjenterprises.com/CCPRO/ShoppingCart  and a 404 error comes up with page not found.

When I click on "Checkout", a url is formed:  https://www.tandjenterprises.com/CCPRO/CheckoutIntro and a 404 error comes up with page not found.

When I click on "Your Account", a url is formed:  https://www.tandjenterprises.com/CCPRO/AccountOverview and a 404 error comes up with page not found.

When I click on "Contact", a url is formed:  http://www.tandjenterprises.com/CCPRO/Contact  and a 404 error comes up with page not found.

When I click on Logout, a url is formed:  https://www.tandjenterprises.com/CCPRO/AccountLogout and a 404 error comes up with page not found.

None of the Menu links are being displayed on the cart displays. 

We are dead in the water with a non-functioning shopping cart.   How can this be resolved?

Offline

 

#2 08-22-2012 14:43:25

Aircut
Member
Registered: 09-22-2003
Posts: 235
Website

Re: Several things are not working in V8 after the install.

did you adjust  your .htaccess file after the install
http://wiki.kryptronic.com/CCP8SearchEngineOptimization

Offline

 

#3 08-22-2012 14:57:42

webmaster
Administrator
From: York, PA
Registered: 04-20-2001
Posts: 19818
Website

Re: Several things are not working in V8 after the install.

That's the issue - implement the new SEO rules in your .htaccess.


Nick Hendler

Offline

 

#4 08-22-2012 16:07:44

ThomasGiannou
Member
Registered: 02-10-2007
Posts: 184

Re: Several things are not working in V8 after the install.

The Post Install updates were not done, so that should resolve the issue.  Thank you.

Offline

 

#5 08-22-2012 19:38:12

ThomasGiannou
Member
Registered: 02-10-2007
Posts: 184

Re: Several things are not working in V8 after the install.

The left and right hand menu options are not displaying on the shopping cart.   What can I do to correct this problem?

Offline

 

#6 08-22-2012 19:56:18

jj1987
Member
From: Orlando, FL
Registered: 07-14-2008
Posts: 502
Website

Re: Several things are not working in V8 after the install.

ThomasGiannou wrote:

The left and right hand menu options are not displaying on the shopping cart.   What can I do to correct this problem?

Can you post your skin.php file?



-James Garrett

Offline

 

#7 08-22-2012 20:03:12

ThomasGiannou
Member
Registered: 02-10-2007
Posts: 184

Re: Several things are not working in V8 after the install.

Ok... here's the contents of my skin.php file:

<?php /* PHP FUNCTION: Skin startup */

      $skinfunc =& $this->include_skinfunc('CORE_SkinFunc');

      extract($skinfunc->startup()); ?>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="content-type" content="text/html; charset=ISO-8859-1" />
<meta name="generator" content="Kryptronic Software" />
<meta name="keywords" content="<?php print $metakeywords; ?>" />
<meta name="description" content="<?php print $metadesc; ?>" />
<?php /* PHP FUNCTION: rints the robots tag */
$skinfunc->robotstag(); ?>
<base href="<?php print $disp_baseurl; ?>" />
<link rel="stylesheet" type="text/css" media="all" href="skins/Default/css/all.css" />
<?php /* PHP FUNCTION: Prints JavaScript Library code */
$skinfunc->namespace('core','jslib'); ?>
<title><?php print $metatitle; ?></title>
</head>
<body>
<div id="skin_wrapper_full"><div id="skin_wrapper">
<table id="skin_ct">
<tr>
<td id="skin_ct_lcol_head">
<?php if (!(empty($link_home))) {?>
<a href="<?php print $link_home; ?>" title="Home"><img src="skins/Default/media/CCPLogo.gif" alt="Home" width="151" height="40" /></a>

<?php } else { ?>
<img src="skins/Default/media/CCPLogo.gif" alt="Home" width="151" height="40" />
<?php } ?>
</td>
<td id="skin_ct_rcol_head" colspan="2">
<div id="skin_menu_head">
<ul>
<?php
if (!(empty($link_home)))     {print '<li><a href="' . $link_home . '" title="Home">Home</a></li>';}
if (!(empty($link_cart)))     {print '<li><a href="' . $link_cart . '" title="Shopping Cart">Shopping Cart</a></li>';}
if (!(empty($link_checkout))) {print '<li><a href="' . $link_checkout . '" title="Checkout">Checkout</a></li>';}
if (!(empty($link_account)))  {print '<li><a href="' . $link_account . '" title="Your Account">Your Account</a></li>';}
if (!(empty($link_contact)))  {print '<li><a href="' . $link_contact . '" title="Contact">Contact</a></li>';}
?>
</ul>
</div>
<div id="skin_headacct">
<?php /* PHP FUNCTION: Include the miniacctlogin namespace to print either a quick login info. */
$skinfunc->namespace('core','miniacctlogin'); ?>
</div>
</td>
</tr>
<tr>
<td id="skin_ct_lcol">
<?php /* PHP FUNCTION: Include the frontend menus namespace.  Pass LEFT as the menu id here. */
$skinfunc->namespace('core','skinwidgets','LEFT'); ?>
</td>
<td id="skin_ct_mcol">
<?php /* PHP FUNCTION: Prints the page title.   */
$skinfunc->titletag($disp_title); ?>
<div id="skin_content">



<?php /* PHP FUNCTION: Print the content for the page.   */

$skinfunc->content(); ?>



</div>



</td>



<td id="skin_ct_rcol">



<p><b><font color="#800000"><a href="http://www.tandjenterprises.com/">

<font color="#800000">Return to main web site<br>

Home page T&amp;J Enterprises</font></a></font></b></p>



<?php /* PHP FUNCTION: Include the frontend menus namespace.  Pass RIGHT as the menu id here. */

$skinfunc->namespace('core','skinwidgets','RIGHT'); ?>



</td>



</tr>



</table>



</div>



<div id="skin_footer">



<?php /* PHP FUNCTION: Print the site owner's address and phone numbers here. */

$skinfunc->printaddphone(); ?>



<p>&copy; <?php print $disp_year . ' ' . $site_name; ?>. All rights reserved worldwide.</p>



<p><a href="https://kryptronic.com/" title="Kryptronic"><img src="media/core/powered_core.png" alt="Kryptronic Powered" width="79" height="24" /></a>

&nbsp;<img src="media/core/valid-xhtml10.png" alt="Valid XHTML" width="79" height="24" />

&nbsp;<img src="media/core/valid-css.png" alt="Valid CSS" width="79" height="24" /></p>



</div>



</div>



<?php /* PHP FUNCTION: Run the debug and closure function. */

$skinfunc->debug(); ?>
</body>
</html>

Offline

 

#8 08-22-2012 20:10:41

jj1987
Member
From: Orlando, FL
Registered: 07-14-2008
Posts: 502
Website

Re: Several things are not working in V8 after the install.

Change
$skinfunc->namespace('core','skinwidgets','LEFT');
To
$skinfunc->xnamespace('core','skinwidgets','SIDEMENU');



-James Garrett

Offline

 

#9 08-22-2012 20:20:07

ThomasGiannou
Member
Registered: 02-10-2007
Posts: 184

Re: Several things are not working in V8 after the install.

I made the code change to the skin.php and now I get this error message:

Fatal error: Call to undefined method CORE_SkinFunc::xnamespace() in /home/thomas/public_html/CCPRO/skins/Default/skin.php on line 85

Should the xnamespace read namespace?

Offline

 

#10 08-22-2012 20:29:35

ThomasGiannou
Member
Registered: 02-10-2007
Posts: 184

Re: Several things are not working in V8 after the install.

I changed the xnamespace to namesapace and the left menu seems to be present now.   What do I do for the Right menu?

Also, I deleted all the test database items that loaded up with V8, but there are a couple of featured images showing up under the left side menu now.   How do I get rid of those image displays?

Offline

 

#11 08-22-2012 20:34:19

jj1987
Member
From: Orlando, FL
Registered: 07-14-2008
Posts: 502
Website

Re: Several things are not working in V8 after the install.

ThomasGiannou wrote:

I changed the xnamespace to namesapace and the left menu seems to be present now.   What do I do for the Right menu?

Also, I deleted all the test database items that loaded up with V8, but there are a couple of featured images showing up under the left side menu now.   How do I get rid of those image displays?

Looks like you haven't updated your skin file according to the upgrade instructions-- I would suggest going through that again.  It should be xnamespace so that it's PHP 5.3 compatible



-James Garrett

Offline

 

#12 08-22-2012 21:51:52

ThomasGiannou
Member
Registered: 02-10-2007
Posts: 184

Re: Several things are not working in V8 after the install.

I put in the < core:content />   statement from the instructions on the display skin changes, but now I'm getting a syntax error on the skin.   What should the format for that statement be?   

Until I get this fixed, nothing in the cart will display.

Offline

 

#13 08-22-2012 22:17:09

jj1987
Member
From: Orlando, FL
Registered: 07-14-2008
Posts: 502
Website

Re: Several things are not working in V8 after the install.

ThomasGiannou wrote:

I put in the < core:content />   statement from the instructions on the display skin changes, but now I'm getting a syntax error on the skin.   What should the format for that statement be?   

Until I get this fixed, nothing in the cart will display.

Which instructions are you following?  I haven't done an upgrade yet so I'm not sure what step you are referring to.



-James Garrett

Offline

 

#14 08-22-2012 22:28:18

ThomasGiannou
Member
Registered: 02-10-2007
Posts: 184

Re: Several things are not working in V8 after the install.

I am following the Instructions for Display Skin Changes.

Near the end of the instructions they have you delete a couple of lines and add the statement:

< core:content />

Now I'm getting a syntax error in the skin.  "Parse error: syntax error, unexpected '<' in /home/thomas/public_html/CCPRO/skins/Default/skin.php on line 79.

Line 79 seems to be that <core:content/> code.


The code for the skin (after changes were made) is below.

<?php /* PHP FUNCTION: Skin startup */
      $skinfunc =& $this->include_skinfunc('CORE_SkinFunc');
      extract($skinfunc->startup()); ?>

<!DOCTYPE html PUBLIC '-//W3C//DTD XHTML+RDFa 1.0//EN' 'http://www.w3.org/MarkUp/DTD/xhtml-rdfa-1.dtd'>

<html xmlns="http://www.w3.org/1999/xhtml" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>

<link rel="stylesheet" type="text/css" media="all" href="media/skins/css/all.css" />

<link rel="stylesheet" type="text/css" media="all" href="skins/Default/css/all.css" />

<?php /* PHP FUNCTION: Prints JavaScript Library code */
$skinfunc->xnamespace('core','jslib'); ?>


</head>

<body>

<div id="skin_wrapper_full"><div id="skin_wrapper">

<table id="skin_ct">

<tr>

<td id="skin_ct_lcol_head">

<?php if (!(empty($link_home))) {?>
<a href="<?php print $link_home; ?>" title="Home"><img src="skins/Default/media/CCPLogo.gif" alt="Home" width="151" height="40" /></a>
<?php } else { ?>
<img src="skins/Default/media/CCPLogo.gif" alt="Home" width="151" height="40" />
<?php } ?>

</td>

<td id="skin_ct_rcol_head" colspan="2">

<div id="skin_menu_head">

<ul>

<?php
if (!(empty($link_home)))     {print '<li><a href="' . $link_home . '" title="Home">Home</a></li>';}
if (!(empty($link_cart)))     {print '<li><a href="' . $link_cart . '" title="Shopping Cart">Shopping Cart</a></li>';}
if (!(empty($link_checkout))) {print '<li><a href="' . $link_checkout . '" title="Checkout">Checkout</a></li>';}
if (!(empty($link_account)))  {print '<li><a href="' . $link_account . '" title="Your Account">Your Account</a></li>';}
if (!(empty($link_contact)))  {print '<li><a href="' . $link_contact . '" title="Contact">Contact</a></li>';}
?>

</ul>

</div>

<div id="skin_headacct">

<?php /* PHP FUNCTION: Include the miniacctlogin namespace to print either a quick login info. */
$skinfunc->xnamespace('core','miniacctlogin'); ?>

</div>

</td>

</tr>

<tr>

<td id="skin_ct_lcol">

<?php /* PHP FUNCTION: Include the frontend menus namespace.  Pass LEFT as the menu id here. */
$skinfunc->xnamespace('core','skinwidgets','SIDEMENU'); ?>

</td>

<td id="skin_ct_mcol">

<?php /* PHP FUNCTION: Prints the page title.   */
< core:content />
</td>

<td id="skin_ct_rcol">

<p><b><font color="#800000"><a href="http://www.tandjenterprises.com/">
<font color="#800000">Return to main web site<br>
Home page T&amp;J Enterprises</font></a></font></b></p>

<?php /* PHP FUNCTION: Include the frontend menus namespace.  Pass RIGHT as the menu id here. */
$skinfunc->xnamespace('core','skinwidgets','SIDEMENU'); ?>

</td>

</tr>

</table>

</div>

<div id="skin_footer">

<?php /* PHP FUNCTION: Print the site owner's address and phone numbers here. */
$skinfunc->printaddphone(); ?>

<p>&copy; <?php print $disp_year . ' ' . $site_name; ?>. All rights reserved worldwide.</p>

<p><a href="https://kryptronic.com/" title="Kryptronic"><img src="media/core/powered_core.png" alt="Kryptronic Powered" width="79" height="24" /></a>
&nbsp;<img src="media/core/valid-xhtml10.png" alt="Valid XHTML" width="79" height="24" />
&nbsp;<img src="media/core/valid-css.png" alt="Valid CSS" width="79" height="24" /></p>

</div>

</div>

<?php /* PHP FUNCTION: Run the debug and closure function. */
$skinfunc->debug(); ?>

</body>

</html>

Offline

 

#15 08-23-2012 04:00:55

Aircut
Member
Registered: 09-22-2003
Posts: 235
Website

Re: Several things are not working in V8 after the install.

i couldn't make my skin works either, i had broken images all over the place. i thought it was the .htaccess but not, because the default skin worked well, i am now using the default skin DESKTOP and trying to modify it to the old look, but still having issues showing products on the splash page. and various email formatting issues..... this upgrade is not that smooth.... i even asked myself why the pre/post database modifications could not be done by the installer.... i hoped i did the right thing getting the v8 and waiting for v8.1

Offline

 

#16 08-23-2012 07:49:01

webmaster
Administrator
From: York, PA
Registered: 04-20-2001
Posts: 19818
Website

Re: Several things are not working in V8 after the install.

Change:

Code:

<?php /* PHP FUNCTION: Prints the page title.   */
< core:content />

To:

Code:

<core:content />

You've got an open PHP tag there that shouldn't be.


Nick Hendler

Offline

 

#17 08-23-2012 10:29:34

ThomasGiannou
Member
Registered: 02-10-2007
Posts: 184

Re: Several things are not working in V8 after the install.

I went back through the skin.php again with the modifications and that seemed to correct the problem.   But that skin.php file looked like heck on the expanded product displays that I dumped it and went to the desktop skin instead.  There's a bit of work to do with that skin, but at least it works.   Thank's for looking at this problem.

So far, this V8 cart is looking excellent!

Offline

 

#18 08-23-2012 16:36:16

webmaster
Administrator
From: York, PA
Registered: 04-20-2001
Posts: 19818
Website

Re: Several things are not working in V8 after the install.

Thanks smile


Nick Hendler

Offline

 

Board footer