Kryptronic Software Support Forum

You are viewing this forum as a guest. Login to an existing account, or create a new account, to reply to topics and to create new topics.

#1 08-22-2012 06:04:20

From: Bristol, UK
Registered: 08-25-2008
Posts: 141

Upgrade to 8 from 6, can't edit any products - Reviews problem

I've imported my V6 shop using the converter, but am unable to save any changes made to existing products. There are two errors flagged:
The first is in "Display": Product Detail Display Type needs to be set to "Default", which can be done through the web interface so more an annoyance that an error. See later in posting for a general fix.
The second is in "Reviews"  where both "Average Overall Review Score" and "Number of Approved Reviews" were shown as "Not Applicable". There is no way to change these fields. I've tried with Reviews on the store both turned on and off and still get the same error.

The way I solved it was to run a raw database command
System Dashboard > System > Database > Raw Database Admin

Then run


update ecom_prod set reviewsavg=0, reviewsnum=0 where reviewsavg="";

I could then edit and save the pre-existing products

To solve the first problem for all products, run


update ecom_prod set lgdisp="default" where lgdisp="noimg";

Last edited by bbac (08-22-2012 06:05:52)



#2 08-22-2012 08:03:09

From: York, PA
Registered: 04-20-2001
Posts: 19804

Re: Upgrade to 8 from 6, can't edit any products - Reviews problem

Thanks for the update.  I've added these commands to the importers.  Sorry I missed them.

Nick Hendler



Board footer