Kryptronic Software Support Forum

You are viewing this forum as a guest. Login to an existing account, or create a new account, to reply to topics and to create new topics.

#51 03-05-2012 15:11:26

daviat
Member
Registered: 11-18-2004
Posts: 1096

Re: Is CCP compatible with PHP 5.3.8?

Thanks Jeremy

Offline

 

#52 03-05-2012 20:18:09

dh783
Moderator
From: Avondale, Arizona
Registered: 04-06-2005
Posts: 6233
Website

Re: Is CCP compatible with PHP 5.3.8?

You can't get PCI compliance on PHP 5.2.x any more, ccp 6 can be ran on PHP 5.3.x.

John

Offline

 

#53 03-06-2012 09:29:56

cyberws
Member
From: Atlanta, GA
Registered: 02-05-2004
Posts: 756

Re: Is CCP compatible with PHP 5.3.8?

CCP 5.3 doesn't appear to be PHP 5.3.x ready.  In fact the split calls make it incompatible.  As for PCI compliance it depends on what payment systems one uses on whether that is necessary.


Jeremy O

Production CCP .:. Version 6 w/QuickBuy and many in house hacks
Skills: PHP & Perl programming, Solaris & Linux server administration, Oracle OCP training and MySQL experience

Offline

 

#54 03-07-2012 17:12:50

cyberws
Member
From: Atlanta, GA
Registered: 02-05-2004
Posts: 756

Re: Is CCP compatible with PHP 5.3.8?

I ran PHP 5.3 compatibility check against CCP 6.x and below is the output showing it is NOT PHP 5.3 compatible and what could be done to fix it.  The fixes are easy just a matter of doing them.  This may help someone out:

FILE: /path/to/ccp/apps/ccp0/CCP/CCP.php
--------------------------------------------------------------------------------
FOUND 0 ERROR(S) AND 2 WARNING(S) AFFECTING 2 LINE(S)
--------------------------------------------------------------------------------
1318 | WARNING | [PHP 5.3] The use of function split() is discouraged; use
      |         | preg_split() instead
1340 | WARNING | [PHP 5.3] The use of function split() is discouraged; use
      |         | preg_split() instead
--------------------------------------------------------------------------------


FILE: /path/to/ccp/apps/ccp0/CCP/includes/formfield_captcha.php
--------------------------------------------------------------------------------
FOUND 0 ERROR(S) AND 1 WARNING(S) AFFECTING 1 LINE(S)
--------------------------------------------------------------------------------
17 | WARNING | [PHP 5.3] The use of function split() is discouraged; use
    |         | preg_split() instead
--------------------------------------------------------------------------------


FILE: /path/to/ccp/apps/ccp0/CCP/includes/olpform.php
--------------------------------------------------------------------------------
FOUND 0 ERROR(S) AND 1 WARNING(S) AFFECTING 1 LINE(S)
--------------------------------------------------------------------------------
339 | WARNING | [PHP 5.3] The use of function split() is discouraged; use
     |         | preg_split() instead
--------------------------------------------------------------------------------


FILE: /path/to/ccp/apps/ccp0/CCP_Cart/CCP_Cart.php
--------------------------------------------------------------------------------
FOUND 0 ERROR(S) AND 7 WARNING(S) AFFECTING 7 LINE(S)
--------------------------------------------------------------------------------
  552 | WARNING | [PHP 5.3] The use of function split() is discouraged; use
      |         | preg_split() instead
  584 | WARNING | [PHP 5.3] The use of function split() is discouraged; use
      |         | preg_split() instead
  593 | WARNING | [PHP 5.3] The use of function split() is discouraged; use
      |         | preg_split() instead
  622 | WARNING | [PHP 5.3] The use of function split() is discouraged; use
      |         | preg_split() instead
  631 | WARNING | [PHP 5.3] The use of function split() is discouraged; use
      |         | preg_split() instead
1688 | WARNING | [PHP 5.3] The use of function split() is discouraged; use
      |         | preg_split() instead
1690 | WARNING | [PHP 5.3] The use of function split() is discouraged; use
      |         | preg_split() instead
--------------------------------------------------------------------------------


FILE: /path/to/ccp/apps/ccp0/CCP_Prod/CCP_Prod.php
--------------------------------------------------------------------------------
FOUND 0 ERROR(S) AND 2 WARNING(S) AFFECTING 2 LINE(S)
--------------------------------------------------------------------------------
815 | WARNING | [PHP 5.3] The use of function split() is discouraged; use
     |         | preg_split() instead
831 | WARNING | [PHP 5.3] The use of function split() is discouraged; use
     |         | preg_split() instead
--------------------------------------------------------------------------------


FILE: /path/to/ccp/apps/ccp0/CCP_Ship/CCP_Ship.php
--------------------------------------------------------------------------------
FOUND 0 ERROR(S) AND 3 WARNING(S) AFFECTING 3 LINE(S)
--------------------------------------------------------------------------------
1251 | WARNING | [PHP 5.3] The use of function split() is discouraged; use
      |         | preg_split() instead
1338 | WARNING | [PHP 5.3] The use of function split() is discouraged; use
      |         | preg_split() instead
1395 | WARNING | [PHP 5.3] The use of function split() is discouraged; use
      |         | preg_split() instead
--------------------------------------------------------------------------------


FILE: /path/to/ccp/apps/ccp0/CCP_Ship/ext/fedex.php
--------------------------------------------------------------------------------
FOUND 0 ERROR(S) AND 1 WARNING(S) AFFECTING 1 LINE(S)
--------------------------------------------------------------------------------
923 | WARNING | [PHP 5.3] The use of function split() is discouraged; use
     |         | preg_split() instead
--------------------------------------------------------------------------------


FILE: /path/to/ccp/core/KHXC/KHXC.php
--------------------------------------------------------------------------------
FOUND 0 ERROR(S) AND 16 WARNING(S) AFFECTING 13 LINE(S)
--------------------------------------------------------------------------------
  932 | WARNING | [PHP 5.3] INI directive 'safe_mode' is deprecated.
  934 | WARNING | [PHP 5.3] INI directive 'safe_mode' is deprecated.
  936 | WARNING | [PHP 5.3] INI directive 'safe_mode' is deprecated.
  938 | WARNING | [PHP 5.3] INI directive 'safe_mode' is deprecated.
  942 | WARNING | [PHP 5.3] INI directive 'safe_mode' is deprecated.
  942 | WARNING | [PHP 5.3] INI directive 'safe_mode' is deprecated.
  969 | WARNING | [PHP 5.3] INI directive 'magic_quotes_runtime' is deprecated.
  971 | WARNING | [PHP 5.3] INI directive 'magic_quotes_runtime' is deprecated.
  973 | WARNING | [PHP 5.3] INI directive 'magic_quotes_runtime' is deprecated.
  975 | WARNING | [PHP 5.3] INI directive 'magic_quotes_runtime' is deprecated.
  979 | WARNING | [PHP 5.3] INI directive 'magic_quotes_runtime' is deprecated.
  979 | WARNING | [PHP 5.3] INI directive 'magic_quotes_runtime' is deprecated.
1334 | WARNING | [PHP 5.3] The use of function dl() is discouraged
1334 | WARNING | [PHP 5.3] The use of function dl() is discouraged
1902 | WARNING | [PHP 5.3] The use of function split() is discouraged; use
      |         | preg_split() instead
1903 | WARNING | [PHP 5.3] The use of function split() is discouraged; use
      |         | preg_split() instead
--------------------------------------------------------------------------------


FILE: /path/to/ccp/core/KHXC/includes/formfield_captcha.php
--------------------------------------------------------------------------------
FOUND 0 ERROR(S) AND 1 WARNING(S) AFFECTING 1 LINE(S)
--------------------------------------------------------------------------------
17 | WARNING | [PHP 5.3] The use of function split() is discouraged; use
    |         | preg_split() instead
--------------------------------------------------------------------------------


FILE: /path/to/ccp/core/KHXC/tasks_startup/0050_regglob.php
--------------------------------------------------------------------------------
FOUND 0 ERROR(S) AND 2 WARNING(S) AFFECTING 1 LINE(S)
--------------------------------------------------------------------------------
84 | WARNING | [PHP 5.3] INI directive 'register_globals' is deprecated.
84 | WARNING | [PHP 5.3] INI directive 'register_globals' is deprecated.
--------------------------------------------------------------------------------


FILE: ...path/to/ccp/core/KHXC/tasks_startup/0100_magicquot.php
--------------------------------------------------------------------------------
FOUND 0 ERROR(S) AND 4 WARNING(S) AFFECTING 2 LINE(S)
--------------------------------------------------------------------------------
102 | WARNING | [PHP 5.3] INI directive 'magic_quotes_gpc' is deprecated.
102 | WARNING | [PHP 5.3] INI directive 'magic_quotes_gpc' is deprecated.
108 | WARNING | [PHP 5.3] INI directive 'magic_quotes_sybase' is deprecated.
108 | WARNING | [PHP 5.3] INI directive 'magic_quotes_sybase' is deprecated.
--------------------------------------------------------------------------------


FILE: /path/to/ccp/core/KHXC_App/KHXC_App.php
--------------------------------------------------------------------------------
FOUND 0 ERROR(S) AND 1 WARNING(S) AFFECTING 1 LINE(S)
--------------------------------------------------------------------------------
1904 | WARNING | [PHP 5.3] The use of function split() is discouraged; use
      |         | preg_split() instead
--------------------------------------------------------------------------------


FILE: /path/to/ccp/pear/File/Find.php
--------------------------------------------------------------------------------
FOUND 1 ERROR(S) AFFECTING 1 LINE(S)
--------------------------------------------------------------------------------
132 | ERROR | [PHP 5.3] Assigning the return value of new by reference is
     |       | deprecated in PHP 5.3
--------------------------------------------------------------------------------


FILE: /path/to/ccp/pear/Mail.php
--------------------------------------------------------------------------------
FOUND 1 ERROR(S) AFFECTING 1 LINE(S)
--------------------------------------------------------------------------------
154 | ERROR | [PHP 5.3] Assigning the return value of new by reference is
     |       | deprecated in PHP 5.3
--------------------------------------------------------------------------------


FILE: /path/to/ccp/pear/Mail/mail.php
--------------------------------------------------------------------------------
FOUND 0 ERROR(S) AND 1 WARNING(S) AFFECTING 1 LINE(S)
--------------------------------------------------------------------------------
124 | WARNING | [PHP 5.3] INI directive 'safe_mode' is deprecated.
--------------------------------------------------------------------------------


FILE: /path/to/ccp/pear/Mail/mime.php
--------------------------------------------------------------------------------
FOUND 0 ERROR(S) AND 2 WARNING(S) AFFECTING 2 LINE(S)
--------------------------------------------------------------------------------
384 | WARNING | [PHP 5.3] The use of function set_magic_quotes_runtime() is
     |         | discouraged
388 | WARNING | [PHP 5.3] The use of function set_magic_quotes_runtime() is
     |         | discouraged
--------------------------------------------------------------------------------


FILE: /path/to/ccp/pear/Mail/mimeDecode.php
--------------------------------------------------------------------------------
FOUND 1 ERROR(S) AFFECTING 1 LINE(S)
--------------------------------------------------------------------------------
324 | ERROR | [PHP 5.3] Assigning the return value of new by reference is
     |       | deprecated in PHP 5.3
--------------------------------------------------------------------------------


FILE: /path/to/ccp/pear/Mail/smtp.php
--------------------------------------------------------------------------------
FOUND 1 ERROR(S) AFFECTING 1 LINE(S)
--------------------------------------------------------------------------------
210 | ERROR | [PHP 5.3] Assigning the return value of new by reference is
     |       | deprecated in PHP 5.3
--------------------------------------------------------------------------------


FILE: /path/to/ccp/pear/Net/SMTP.php
--------------------------------------------------------------------------------
FOUND 1 ERROR(S) AFFECTING 1 LINE(S)
--------------------------------------------------------------------------------
126 | ERROR | [PHP 5.3] Assigning the return value of new by reference is
     |       | deprecated in PHP 5.3
--------------------------------------------------------------------------------


FILE: /path/to/ccp/pear/PEAR.php
--------------------------------------------------------------------------------
FOUND 2 ERROR(S) AND 3 WARNING(S) AFFECTING 4 LINE(S)
--------------------------------------------------------------------------------
563 | ERROR   | [PHP 5.3] Assigning the return value of new by reference is
     |         | deprecated in PHP 5.3
566 | ERROR   | [PHP 5.3] Assigning the return value of new by reference is
     |         | deprecated in PHP 5.3
739 | WARNING | [PHP 5.3] INI directive 'safe_mode' is deprecated.
753 | WARNING | [PHP 5.3] The use of function dl() is discouraged
753 | WARNING | [PHP 5.3] The use of function dl() is discouraged
--------------------------------------------------------------------------------

Last edited by cyberws (03-07-2012 17:14:45)


Jeremy O

Production CCP .:. Version 6 w/QuickBuy and many in house hacks
Skills: PHP & Perl programming, Solaris & Linux server administration, Oracle OCP training and MySQL experience

Offline

 

#55 03-08-2012 07:41:01

Dave
Member
Registered: 07-05-2003
Posts: 11233

Re: Is CCP compatible with PHP 5.3.8?

All of the issues with the PEAR library are easily resolved by downloading and installing the latest PEAR package. The one bundled with CCP is several years old and very out of date.

Offline

 

#56 03-08-2012 08:17:15

htw_simon
Member
From: UK
Registered: 11-20-2007
Posts: 83
Website

Re: Is CCP compatible with PHP 5.3.8?

dh783 wrote:

You can't get PCI compliance on PHP 5.2.x any more, ccp 6 can be ran on PHP 5.3.x.

John

We are PCI compliant with PHP 5.2.17, so yes you can - passed a scan just last week.

Simon

Offline

 

#57 03-08-2012 10:26:27

cyberws
Member
From: Atlanta, GA
Registered: 02-05-2004
Posts: 756

Re: Is CCP compatible with PHP 5.3.8?

I realize Nick is wanting to make his software as easy as possible to install and thus included the PEAR functions.  However it would be nice if the installer would check the server and if the functions are already loaded into the PHP install on the server skip the included CCP one.

More often that not I have seen PCI compliance problems are due to PHP.ini settings and less to do with a specific version.  It has been known to happen but P.2.17, as HTW Simon as pointed out, is PCI compliant given the correct settings.


Jeremy O

Production CCP .:. Version 6 w/QuickBuy and many in house hacks
Skills: PHP & Perl programming, Solaris & Linux server administration, Oracle OCP training and MySQL experience

Offline

 

#58 03-12-2012 10:45:28

innerwolf
Member
From: Leicester UK
Registered: 03-21-2007
Posts: 118
Website

Re: Is CCP compatible with PHP 5.3.8?

Hi, where would I find the latest PEAR bundle? My hosting updated to 5.3 a month or so back and did a temporary revert on it until I could sort this out which is nearly up so I need to sort it asap.


wwwbritishdog.net - Dog Training Equipment and all that stuff
wwwinnerwolf.co.uk - For Dog and Owners, that Love the Great Outdoors
wwwpickledshrimp.co.uk - Kitewing, If there's Wind, Wing it!

Offline

 

#59 03-12-2012 11:02:52

cyberws
Member
From: Atlanta, GA
Registered: 02-05-2004
Posts: 756

Re: Is CCP compatible with PHP 5.3.8?

Please note I have not tested this PEAR.php with CCP but the download link:

http://pear.php.net/package/PEAR/download

PHP 5.4 is now out and these above errors will now cause fault crashes.  If PHP 5.3 is set to all errors it will crash too.


Jeremy O

Production CCP .:. Version 6 w/QuickBuy and many in house hacks
Skills: PHP & Perl programming, Solaris & Linux server administration, Oracle OCP training and MySQL experience

Offline

 

#60 03-12-2012 12:43:17

innerwolf
Member
From: Leicester UK
Registered: 03-21-2007
Posts: 118
Website

Re: Is CCP compatible with PHP 5.3.8?

Thank you. So making the changes in the above list of erors won;t solve the issue? Is that correct?


wwwbritishdog.net - Dog Training Equipment and all that stuff
wwwinnerwolf.co.uk - For Dog and Owners, that Love the Great Outdoors
wwwpickledshrimp.co.uk - Kitewing, If there's Wind, Wing it!

Offline

 

#61 03-12-2012 13:54:22

cyberws
Member
From: Atlanta, GA
Registered: 02-05-2004
Posts: 756

Re: Is CCP compatible with PHP 5.3.8?

If you make the changes above CCP should work with PHP 5.3.x and probably even PHP 5.4.x.


Jeremy O

Production CCP .:. Version 6 w/QuickBuy and many in house hacks
Skills: PHP & Perl programming, Solaris & Linux server administration, Oracle OCP training and MySQL experience

Offline

 

#62 03-12-2012 14:43:44

webmaster
Administrator
From: York, PA
Registered: 04-20-2001
Posts: 19758
Website

Re: Is CCP compatible with PHP 5.3.8?

Rewriting all of the code to use '=' instead of '=&' will destroy the ability for the program to share and use objects.  Do not do this.  '=&' is and always will be valid PHP.  In PHP 5.3 the '=& new' synstax for loading Pear objects was removed.  This was removed from the codebase of our software beginning with version 7.1.2.  Therefore, anywhere you see '=& new' replace with '=&' if making version 6 software work on PHP 5.3 and above.  There should only be a few instances of that in the entire codebase.


Nick Hendler

Offline

 

#63 03-12-2012 15:05:20

cyberws
Member
From: Atlanta, GA
Registered: 02-05-2004
Posts: 756

Re: Is CCP compatible with PHP 5.3.8?

It appears you can do either "=&" or "=new" but not the old "=& new".

http://www.php.net/manual/en/language.o … .basic.new


Jeremy O

Production CCP .:. Version 6 w/QuickBuy and many in house hacks
Skills: PHP & Perl programming, Solaris & Linux server administration, Oracle OCP training and MySQL experience

Offline

 

Board footer